Useful commands for setting up CentOS Linux

Find out what version you're running
cat /etc/redhat-release

find out if 64- or 32-bit
uname -m

install with yum
yum install

uninstall with yum
yum remove

remove or delete a file
rm <filename>

installing RHEL EPEL repo
http://www.rackspace.com/knowledge_center/article/installing-rhel-epel-repo-on-centos-5x-or-6x

more yum stuff
http://www.cyberciti.biz/faq/rhel-centos-fedora-linux-yum-command-howto/

 

weird "issues"
(aka n00b mistakes)
warning: epel-release-6-5.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 0608b895
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-5.noarch
rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-5.noarch

Installing for wrong version! (see above to check your version)

Useful commands for setting up CentOS Linux

Find out what version you're running
cat /etc/redhat-release

find out if 64- or 32-bit
uname -m

install with yum
yum install

uninstall with yum
yum remove

remove or delete a file
rm

installing RHEL EPEL repo
http://www.rackspace.com/knowledge_center/article/installing-rhel-epel-repo-on-centos-5x-or-6x

more yum stuff:
http://www.cyberciti.biz/faq/rhel-centos-fedora-linux-yum-command-howto/

 

weird "issues" (aka n00b mistakes)
warning: epel-release-6-5.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 0608b895
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-5.noarch
rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-5.noarch


Installing for wrong version! (see above to check your version)

Useful commands for setting up CentOS Linux

Find out what version you're running
cat /etc/redhat-release

find out if 64- or 32-bit
uname -m

install with yum
yum install

uninstall with yum
yum remove

remove or delete a file
rm <filename>

installing RHEL EPEL repo
http://www.rackspace.com/knowledge_center/article/installing-rhel-epel-repo-on-centos-5x-or-6x

more yum stuff
http://www.cyberciti.biz/faq/rhel-centos-fedora-linux-yum-command-howto/

 

weird "issues"
(aka n00b mistakes)
warning: epel-release-6-5.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 0608b895
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-5.noarch
rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-5.noarch

Installing for wrong version! (see above to check your version)